AWS has confirmed that the incident is fully resolved. Simpplr features have stabilized, and our engineering teams have verified that all previously impacted functionalities are now operating as expected. We will continue to monitor closely to ensure there are no further disruptions.
At this time, AWS has not yet shared a Root Cause Analysis (RCA). You can track updates and any forthcoming RCA details directly through the AWS Service Health Dashboard: https://health.aws.amazon.com/health/status?ts=20251020
Thank you for your patience and continued partnership! Simpplr Technical Support Team
Posted Oct 21, 2025 - 07:45 UTC
Monitoring
Hello, We are continuing to monitor the ongoing AWS service recovery. AWS has reported that most services in the US-EAST-1 region are stabilizing, with successful instance launches across multiple availability zones. Some customers may still experience intermittent errors with related features but we are rapidly moving towards a resolution.
These issues stem from residual network connectivity problems within AWS infrastructure. As AWS continues to restore full functionality, we are seeing gradual improvement and expect Simpplr features to recover in line with their progress.
While this incident originates outside of Simpplr’s environment, we remain closely engaged and will provide an update as soon as AWS confirms full resolution.
Thank you for your continued patience and understanding, Simpplr Technical Support Team
Posted Oct 20, 2025 - 20:01 UTC
Investigating
Hello, We are currently experiencing issues affecting several features within Simpplr, including newsletter delivery, analytics reporting, carousel display, and video playback, among others.
Our team has identified that these disruptions are related to an ongoing AWS service outage, which is impacting portions of our hosting infrastructure. We are actively monitoring AWS’s progress and will restore full functionality as soon as their services stabilize.
While the issue originates outside of Simpplr’s environment, we are closely coordinating and will provide updates here as new information becomes available.
Next Update: We will share an update as soon as AWS confirms resolution or provides an estimated recovery time.
Thank you for your patience and understanding, Simpplr Technical Support Team