Simpplr Outage || Upgrade Issue

Incident Report for Simpplr

Resolved

Hello Again,

Our Engineering team has deployed the fix to all the impacted instances and the outage has been resolved. Thank you for your patience while we’ve been working on this. We know the disruption may have been frustrating and we really appreciate your patience and support in this matter.

If you continue to have issues please submit a ticket via the support portal.
Posted May 06, 2025 - 09:05 UTC

Identified

Hello All,

Good News!

Our Engineering team was able to identify the issue and has started deploying the fix to customer Orgs. We are in the process of deploying the fix to impacted instances so it might take some time to update all instances.

We’ll continue to share updates as we have them. Thank you for your continued patience and support!
Simpplr Technical Support
Posted May 06, 2025 - 08:05 UTC

Investigating

Our teams have been made aware of the Simpplr outage wherein we can see a 'Simpplr is temporarily unavailable - refresh to try again' error. This appears to have emanated from the latest patch deployment. We are dedicatedly investigating the issue and there is no estimated time to resolve as of yet. We’ll continue to share updates as we have them.
Posted May 06, 2025 - 05:55 UTC