Outage Affecting Simpplr Logins/Vanity URL logins
Incident Report for Simpplr
Resolved
Thank you for your patience as our team worked through this issue. Services has been returned to normal, please feel free to reach out if there is any additional disturbance.

Have a great day ahead!
Simpplr Technical Support Team
Posted Jul 24, 2024 - 13:30 UTC
Investigating
We're currently investigating an outage impacting Simpplr Logins/Vanity URLs. Our team is working to resolve this issue promptly.
Posted Jul 24, 2024 - 12:25 UTC
This incident affected: Login Page and System.