Hi again, We’re pleased to share that the issue impacting video embeds in newsletters has been fully resolved by our Engineering team.
After close collaboration with our video provider’s leadership team, our engineers were able to implement targeted fixes to restore full functionality. We have also put additional monitoring in place to ensure continued stability.
If you continue to experience any related issues, please don’t hesitate to submit a support ticket, and we’ll be happy to help.
Thank you again for your patience and understanding while we worked through this.
Sincerely, Simpplr Technical Support Team
Posted Jul 24, 2025 - 16:36 UTC
Update
Hello Again,
This issue has been escalated to the leadership team of our video provider, and our Engineering team is actively collaborating with them to drive a resolution as quickly as possible.
It has been identified as an intermittent issue. In parallel, our Engineering team is also working to implement mitigations on our end by deploying targeted fixes. At this time, there is no confirmed ETA for resolution.
We are closely monitoring the situation and will continue to provide updates as more information becomes available.
For the most up-to-date information, please refer to our status page. If you need direct assistance, please don’t hesitate to submit a support ticket.
We truly appreciate your patience and understanding as we work through this. Simpplr Technical Support Team
Posted Jul 24, 2025 - 05:52 UTC
Identified
Hi there,
We’ve identified an issue caused by a third-party video provider, which is currently preventing newsletters with embedded videos from sending correctly.
As a temporary workaround, you can:
Include the video as a clickable URL in the newsletter, or
Embed the video on a separate page and link to or promote that page within your newsletter.
We’ll share updates as soon as a permanent fix is in place.
Thank you for your patience! Simpplr Technical Support