Planned Maintenance || July 5th

Incident Report for Simpplr

Resolved

The maintenance has been completed and there is no reported customer impact. Please feel free to reach out with any questions!

Thank you,
Simpplr Technical Support Team
Posted Jul 05, 2025 - 06:41 UTC

Investigating

Our servers are currently undergoing planned maintenance. During this activity customers may experience some downtime and may not be able to access some of the core functionalities. The activity is expected to be completed within 1.5-2 hours.

We will update as soon as we know more.

Thank you,
Simpplr Technical Support
Posted Jul 05, 2025 - 04:38 UTC