Employee Newsletter Degradation
Incident Report for Simpplr
Resolved
Good news!!

The team was able to prioritize a resolution for the Newsletter issue and things is now operating as expected.

Please submit a ticket via the support portal if you have any questions or are still experiencing degraded service.

https://support.simpplr.com/hc/en-us

Have a lovely day!
Simpplr Technical Support
Posted Jun 13, 2023 - 20:52 UTC
Investigating
We are currently investigating reports of Employee Newsletter degradation impacting customers in the form of viewing templates or past newsletters. Sending newsletters is also unavailable.

There is no estimated time to resolve as of yet. We’ll continue to share updates as we have them.

Thank you for your patience,
Simpplr Technical Support
Posted Jun 13, 2023 - 20:32 UTC
This incident affected: Content.