My Team Dashboard slow load times
Incident Report for Simpplr
Resolved
The issue with the My Team Dashboard has been resolved. Please reach out via the Support Portal if you are still experiencing issues.

Thank you for your partnership!
Thanks,
Simpplr Support
Posted Jun 21, 2023 - 18:27 UTC
Identified
We have identified an issue with slow load times on My Team Dashboard, we will be updating the status page with information as it comes to us.

Thank you for your patience as we work towards a resolution!
Thanks,
Simpplr Support
Posted Jun 15, 2023 - 16:27 UTC
This incident affected: My Team Dashboard.